Обновление PostgreSQL до версии 13 в Debian11

Все новости нашего портала
Ответить
ustim
Администратор
Сообщения: 2
Зарегистрирован: 03 июн 2021, 09:01

Обновление PostgreSQL до версии 13 в Debian11

Сообщение ustim »

При обновлении Debian до версии 11, вы можете наткнуться на такое сообщение
Устаревшая основная версия 11

PostgreSQL версии 11 устарела, но серверные или клиентские пакеты все еще установлены.
Пожалуйста, установите последние пакеты (postgresql-12 и postgresql-client-12) и обновите существующие кластеры с помощью pg_upgradecluster (см. Страницу руководства).

Имейте в виду, что при установке postgresql-12 автоматически создается кластер по умолчанию 12 / main.
Если вы хотите обновить кластер 11 / main, вам необходимо удалить уже существующий кластер 12 (pg_dropcluster —stop 12 main, подробности см. На странице руководства).

Старые серверные и клиентские пакеты больше не поддерживаются.
После обновления существующих кластеров пакеты postgresql-11 и postgresql-client-11 должны быть удалены.

Дополнительные сведения см. В / usr / share / doc / postgresql-common / README .Debian.gz.
Итак, что мы делаем:

1. Используйте, dpkg -l | grep postgresql чтобы проверить, какие версии postgres установлены:

Код: Выделить всё

dpkg -l | grep postgresql
2. Запустите pg_lsclusters, ваши 11 и 13 основные кластеры должны быть «в сети».

Код: Выделить всё

pg_lsclusters
Кластер «основной» для 13 уже существует (поскольку он создается по умолчанию при установке пакета). Это сделано для того, чтобы новая установка работала из коробки без необходимости сначала создавать кластер, но, конечно, она конфликтует, когда вы пытаетесь обновить 11 / main, когда также существует 13 / main. Рекомендуемая процедура - удалить кластер 13 используя pg_dropclusterи затем обновить с помощью pg_upgradecluster.

3. Остановите кластер 13 и отсоедините его.

Код: Выделить всё

sudo pg_dropcluster 12 main --stop
4. Обновите кластер 11 до последней версии.

Код: Выделить всё

sudo pg_upgradecluster 11 main
Теперь ваш кластер 11 должен быть «выключен», и вы можете запустить проверку.

Код: Выделить всё

pg_lsclusters
5. Убедитесь, что обновленный кластер работает, затем удалите кластер 11.

Код: Выделить всё

sudo pg_dropcluster 11 main
6. После проверки данных вы можете удалить старые пакеты.

Код: Выделить всё

sudo apt-get purge postgresql-11 postgresql-client-11
Ответить